Wednesday, May 4, 2011

Windows Process Activation Service (WAS) couldn't start , IIS also couldn't start

Ok that my first blog , I hope it will help full for you.
It was a regular day in work , i started my machine and tried to open my sharepoint 2010 site to continue what i was doing, ooooooooooops the HTTP 404 HELL message appeare , WHAT!!!!!.

ok , i checked my IIS and it found that it was not running , Simply i pressed start and again another error that informs me that IIS cannot start, after some googling if found that this message was Informing me that Windows Process Activation Service (WAS) is encountering a problem, i open the event viewer a found three errors:
1- Error ID: 5189
The Windows Process Activation Service failed to generate an application pool config file for application pool '*'. The error type is '0'. To resolve this issue, please ensure that the applicationhost.config file is correct and recommit the last configuration changes made. The data field contains the error number.
2-Error ID: 5036
The configuration manager for Windows Process Activation Service (WAS) did not initialize. The data field contains the error number.
3- Error ID: 5005
Windows Process Activation Service (WAS) is stopping because it encountered an error. The data field contains the error number.

OK, i gone googling for two Horus , where i found a common opinion that my applicationhost.config is corrupted , and i need to rebuild my OS , WHAAAAAAAAAAAT no, I'll lose my data ???!!!

but when i started to give up i found this magical Solution:

To fix this problem, follow these steps:
1.     Click Start , click All Programs, click Accessories, and then right-click Command Prompt.
2.     Click Run as administrator. If you are prompted for an administrator password, type the password. If you are prompted for confirmation, click Continue.
3.     At a command prompt, type the following command, and then press ENTER:
fsutil resource setautoreset true c:\
Note These steps assume that Windows is installed in the default location, on drive C. If this is not the case, adjust the drive letter of the folder path to match your configuration.
4.     Restart the computer.
And it worked ,,, THANX GOD.

6 comments:

  1. thank you and god too. it is really worked!!!!!!!

    ReplyDelete
  2. I tried this fix, but did not work.

    ReplyDelete
  3. not working for me either

    ReplyDelete
  4. Dear Sir, thank you very much. You saved my morning day!

    ReplyDelete